Formas Cuadráticas y criterio de Autovalores

Para el segundo parcial de Algebra y Geometría Analítica II me encuentro con la dificultad de entender como encarar formas cuadráticas en R2 y R3 de manera autodidacta ya que no pude asistir a las ultimas dos clases antes del parical. Para cualquiera en la misma situación o para cualquiera que por x motivo necesite entender este tema recomiendo este pequeño texto de la  Universidad Autónoma de Madrid:

http://www.uam.es/personal_pdi/economicas/portega/web-algebra/capitulo-6/teoria6-2/6-2-teoria.htm

Entre los que se ven los criterios de Menores Principales y de Autovalores para estudiar el comportamiento de las formas F(x,y,z,….,n) y como graficarlas.

Mas adelante voy a subir las prácticas resueltas y otras lecturas que facilitan mucho la cursada, pero será para después del parcial.

Saludos:)

Direccionamiento y Rutas Estaticas

Este este es el primero de una serie de posts sobre distintos laboratorios de simulacion de redes. Los paquetes de software que voy a utilizar para esto son todos freeware u opensource:

  • GNS3
  •  Virtualbox
  •  Quemu
  •  Wireshark (Sniffer)
  •  Nemesis ( Packet Crafter )
  •  PfSense ( Firewall FreeBSD )
  •  Packet tracer.

Los laboratorios estan orientados principalmente para las certificaciones de Cisco CCNA CCNP y CCIE. Cualquier error o duda que se pueda llegar a tener por favor comunicarse a mi correo o comentar, ya que la idea de todo esto es poder llegar a discutir los temas y profundizar sobre los mismos 🙂

Descripcion: Pequeño laboratorio con rutas estaticas para permitir la visualizacion, routers mediante, de dos redes.

Laboratorio en .pkt:  Lab1

Configuracion Router Oracle:

Oracle#sh running-config
Building configuration...
Current configuration : 773 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Oracle
!
!
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool LAN
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
!
!
aaa new-model
!
aaa authentication login default local enable
!
!
!
username joaquin password 0 123
!
!
!
!
interface FastEthernet0/0
ip address 10.10.10.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.10.2
!
!
!
banner motd ^C Bienvenido al router Ora^C
!
!
line con 0
line vty 0 4
!
!
end

Configuracion Router IBM:

IBM#sh running-config
Building configuration...

Current configuration : 673 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname IBM
!
!
ip dhcp excluded-address 192.168.2.1
!
ip dhcp pool LAN
network 192.168.2.0 255.255.255.128
default-router 192.168.2.1
!
!
!
!
interface FastEthernet0/0
ip address 10.10.10.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.2.1 255.255.255.128
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.10.1
!
!
!
banner motd ^C Bienvenido al router IBM ^C
!
!
!
line con 0
line vty 0 4
login
!
!
!
end

Saludos!!

La frontera del arte

Cita

Fue la batalla más larga de cuantas se pelearon en Tuscatlán o en cualquier otra región de El Salvador. Empezó a la medianoche, cuando las primeras granadas cayeron sobre la loma, y duró toda la noche y hasta la tarde del día siguiente. Los militares decían que Cinquera era inexpugnable. Cuatro veces la habían asaltado los guerrilleros, y cuatro veces habían fracasado. La quinta vez, cuando se alzó la bandera blanca en el mástil de la comandancia, los tiros al aire empezaron los festejos.

Julio Ama, que peleaba y fotografiaba la guerra, andaba caminando por las calles. Llevaba su fusil en la mano y la cámara, también cargada y lista para disparar, colgada del cuello. Andaba Julio por las calles, polvorientas, en busca de los hermanos gemelos. Esos gemelos

eran los únicos sobrevivientes de una aldea exterminada por el ejército. Tenían dieciséis años. Les gustaba combatir junto a Julio: y en las entreguerras, él les enseñaba a leer y a fotografiar. En el torbellino de esa batalla, Julio había perdido a los gemelos, y ahora no los veía entre los vivos ni entre los muertos.

Caminó a través del parque. En la esquina de la iglesia, se metió en un callejón. Y entonces, por fin, los encontró. Uno de los gemelos estaba sentado en el suelo, de espaldas contra un muro. Sobre sus rodillas, yacía el otro, bañado en sangre; y a los pies, en cruz, estaban los dos fusiles.

Julio se acercó, quizá dijo algo. El gemelo que vivía no dijo nada, ni se movió: estaba allí, pero no estaba. Sus ojos, que no pestañaban, miraban sin ver, perdidos en alguna parte, en ninguna parte: y en esa cara sin lágrimas estaba toda la guerra y estaba todo el dolor.

Julio dejó su fusil en el suelo y empuñó la cámara. Corrió la película, calculó en un santiamén la luz y la distancia y puso en foco la imagen. Los hermanos estaban en el centro del visor, inmóviles, perfectamente recortados contra el muro recién mordido por las balas.

Julio iba a tomar la foto de su vida, pero el dedo no quiso. Julio lo intentó, volvió a intentarlo, y el dedo no quiso. Entonces, bajó la cámara, sin apretar el disparador, y se retiró en silencio.

La cámara, una Minolta, murió en otra batalla, ahogada en lluvia, un año después.

Eduardo Galeano, El libro de los Abrazos

Triangulo de Pascal – PHP

De wikipedia:

En matemática, el triángulo de Pascal es una representación de los coeficientes binomiales ordenados en forma triangular. Es llamado así en honor al matemático francés Blaise Pascal, quien introdujo esta notación en 1654, en su Traité du triangle arithmétique.

En regiones como China, India o Persia, esta formulación era bien conocida y fue estudiada por matemáticos como Al-Karaji, cinco siglos antes de que Pascal expusiera sus aplicaciones, o por el astrónomo y poeta persa Omar Jayyam (1048-1123). En China es conocido como Triángulo de Yanghui, en honor al matemático Yang Hui, quien lo describió en el año 1303.

Como se sabe, dentro de este pequeño triángulo hay una cantidad ilimitada de informacion que tiene que ver con la combinatoria esencialmente. Su desarrollo en base a series binomiales y números combinatorios es de la siguiente manera:

( Binomio de Newton )

(Fila 3 del triángulo = 1 3 3 1 )

Pero la cuestion no es hablar del triángulo en si mismo ni de sus propiedades ya que wikipedia lo hace bastante bien. Mencionado lo anterior el fin de este código es dibujar el triángulo recursivamente con la propiedad de que:
‘Todo numero que no pertenece a las diagonales externas del triangulo es la suma de sus 2 vecinos en la fila de arriba’

Si alguien quiere mejorar la estetica del mismo, es bienvenido 🙂

 

<?php
 
function par($num){
    if($num%2==0){
        return 1;
    }else{
        return 0;
    }
}
 
function triangulo($fila,$pos){
    $cant=$fila;
    if($fila==1 or $pos==$cant or $pos==1){
        return 1;
    }else if($pos<=$fila){
        $num=triangulo(($fila-1),($pos-1))+triangulo(($fila-1),$pos);
        return $num;
    }
}
 
function triangulo_dibujo($fila,$pos){
    $cant=$fila;
    if($fila==1){
        echo "1<br />";
    }else if($pos==1){
        echo "1 | ";
    }else if($pos==$cant){
        echo "1 <br />";
    }else if($pos<=$fila){
        $num=triangulo(($fila-1),($pos-1))+triangulo(($fila-1),$pos);
        if(par($num)==1){
            echo "<font color='red'>".$num."</font> | ";
        }else{
            echo $num." | ";
        }
    }
}
?>
<div style="text-align:center;border:1px solid;">
<?php
//Dibujamos hasta la fila 23
for ($i=1;$i<=23;$i++){
    for($j=1;$j<=$i;$j++){
        triangulo_dibujo($i,$j);
    }
}
?>
</div>

Quedando así

Saludos!

TAD Pila – PHP

De wiki-pedia

Una pila (stack en inglés) es una lista ordinal o estructura de datos en la que el modo de acceso a sus elementos es de tipo LIFO (del inglés Last In First Out, último en entrar, primero en salir) que permite almacenar y recuperar datos. Esta estructura se aplica en multitud de ocasiones en el área de informática debido a su simplicidad y ordenación implícita de la propia estructura.

Lo que hice con PHP fue crear una clase Pila() con métodos que operan sobre arreglos  haciendo que, si operamos solo con estos metodos se simulara un TAD tipo pila.

Clase Pila.php

<?php
	class Pila{
				 
		 function push(&$pila,&$i){
		 	$pila&#91;$this->countPila($pila)+1] = $i;		 	
		 }
		 
		 function countPila($pila){
		 	return count($pila);		 	
		 }
		 function pop(&$pila){
		 	unset($pila[$this->countPila($pila)]);
		 }
		 
		 function showTop($pila){
		 	if(!$this->isEmpty($pila)){
		 		echo "El elemento ".$this->countPila($pila)." de la Pila es: ".$pila[$this->countPila($pila)]."<br>";
		 	}else{
		 		echo "La pila esta vacia!";
		 	}
		 }
		 
		 function isEmpty($pila){
		 	if($this->countPila($pila) == 0){
		 		return true;
		 	}else{
		 		return false;
		 	}
		 }		
	}
?>

Vemos que tenemos el siguiente conjunto de métodos básicos en esta estructura

Operaciones
Una pila cuenta con 2 operaciones imprescindibles: apilar y desapilar, a las que en las implementaciones modernas de las pilas se suelen añadir más de uso habitual.
Crear: se crea la pila vacía.
Apilar: se añade un elemento a la pila.(push)
Desapilar: se elimina el elemento frontal de la pila.(pop)
Cima: devuelve el elemento que esta en la cima de la pila. (top o peek)
Vacía: devuelve cierto si la pila está vacía o falso en caso contrario.

Ahora un pequeño uso de estos métodos sobre 2 arrays que definimos previamente:

<?php
	$a = new Pila();
	
	$numeros = array();
	$pila = array(); 
	
	//Lleno al array $pila
	for($i=1;$i<=10;$i++){
		$a->push($pila,$i);		
	}
	
	//Muestro $pila
	for($i=$a->countPila($pila);$i>=0;$i--){
		$a->showTop($pila);
		$a->pop($pila);	
	}
	
	echo "<br>";
	
    //Mismo procedimiento con $numeros
	for($i=1;$i<=100;$i++){
		$num = rand($i,200);
		$a->push($numeros, $num);	
	}
	
	for($i=$a->countPila($numeros);$i>=0;$i--){
		$a->showTop($numeros);
		$a->pop($numeros);
	}
		
?>

Vemos que el orden en que se imprimen los valores es el inverso al que se llena la pila (FILO).

Saludos!

Add Sidebar in single Post Pages WordPress

Ya que tuve que lidiar con este temita al configurar el blog, lo escribo ahora asi queda de referencia tanto para mi como para cualquiera que llegue a este rincon de la red.

Es para el theme Twenty Eleven ya que por defecto esta plantilla no trae el sidebar en la vista individual de posts y tampoco se puede configurar desde el desktop.

Hay 2 sencillos pasos a seguir:

1) Desde el editor de plantillas nos paramos ‘en single.php’ y agregamos antes de

<?php get_footer(); ?>

la funcion sidebar

<?php get_sidebar(); ?>

y guardamos.

Con esto logramos tener el sidebar en la vista que queriamos pero explotan las columnas, asi que hay que retocar un poco el css en ‘style.css’ agregando al final del archivo lo siguiente:

.singular #primary {
margin: 0 -26.4% 0 0;
}
 
#nav-single {
display: none;
}
 
.singular .entry-header .entry-meta {
position: relative;
}
 
.singular .hentry {
padding: 0;
}
 
.singular .entry-header, .singular .entry-content, .singular footer.entry-meta, .singular #comments-title {
width: 100%;
}
 
.singular #content, .left-sidebar.singular #content {
margin: 0 34% 0 7.6%;
}
 
.singular article .entry-title {
padding-top: 0;
}
 
.singular .entry-meta .edit-link a {
right: 0;
top: 0;
left: auto;
}

Guardamos y a disfrutar!

Tu vida es privada?

Hoy, leyendo un foro que frecuento, encontré este excelente vídeo en el cual se analiza el flujo de información de los usuarios de las redes sociales (Facebook, Twitter, etc) y como se puede analizar y obtener información muy valiosa de ellos con pocos conocimientos técnicos. Entre otras cosas muy interesantes, me gusto como se utiliza la teoria de grafos para establecer vinculos entre la gente.

Gerardo Richarte en GarageLab 4 Post-Privacidad from GLab1 on Vimeo.